After you Subscribe email your username
and receipt to
goonsquad.me@gmail.com
Membership Options
Pay With Bitcoin
  • 45 Vote(s) - 3.09 Average
  • 5
  • 4
  • 3
  • 2
  • 1
Thread Modes

Maitreya Lara tutorial with dev kit
RiderLibertas Offline
Beginner
Registered

Posts: 10
Threads: 1
Joined: Mar 2016
Reputation: 0
Thanks so much to Zero for the Maitreya Lara tutorial and dev kit!  I'm trying to make some clothing for it and am running into a problem with weighting.  Whenever I change a shape slider to test weighting the body turns and distorts slightly.  The bones, head, hands and feet stay but the body itself seems to turn 270 degrees but not exactly on center of the z axis and it changes size slightly and the neck goes out of alignment.  If I turn the clothing it no longer fits.

Am I doing something wrong?

RiderLibertas Offline
Beginner
Registered

Posts: 10
Threads: 1
Joined: Mar 2016
Reputation: 0
(05-06-2016, 05:48 AM)RiderLibertas Wrote: You are not allowed to view links. Register or Login to view.Thanks so much to Zero for the Maitreya Lara tutorial and dev kit!  I'm trying to make some clothing for it and am running into a problem with weighting.  Whenever I change a shape slider to test weighting the body turns and distorts slightly.  The bones, head, hands and feet stay but the body itself seems to turn 270 degrees but not exactly on center of the z axis and it changes size slightly and the neck goes out of alignment.  If I turn the clothing it no longer fits.

Am I doing something wrong?


I'm attaching a screen shot.  Can't get TinyPic Plugin to work.

Thumbnail(s)
   

Pixel Duster Offline
Elite Member
********
V.I.P

Posts: 85
Threads: 6
Joined: Apr 2016
Reputation: 163
Yikes! I do know the parts aren't linked but I really haven't played with the shape sliders. In fact at present I'm sort of avoiding moving her at all, though in one test I did link the body. I've made some pretty crazy mistakes though! 

I have 2 alts with Maitreya bodies, pretty different shapes, and finally got a top to work on both. Amazingly, I didn't have to use any of the Lara alphas. This kit really rocks.

Pixel Duster Offline
Elite Member
********
V.I.P

Posts: 85
Threads: 6
Joined: Apr 2016
Reputation: 163
Oh you know, one simple thing could be tripping you up. Are you holding down the M key when you import an .obj? That should snap it right to the body.

RiderLibertas Offline
Beginner
Registered

Posts: 10
Threads: 1
Joined: Mar 2016
Reputation: 0
(05-06-2016, 06:20 AM)Pixel Duster Wrote: You are not allowed to view links. Register or Login to view.Oh you know, one simple thing could be tripping you up. Are you holding down the M key when you import an .obj? That should snap it right to the body.

The obj clothing I'm importing snaps to the body just fine, in the right place and right size, no rotation needed.  It's only when I try to change a shape slider that this happens.  Very odd.  It's not the clothing that is moving, it's the body itself.  Note that the bones don't move with it.  I've never seen that before.

RiderLibertas Offline
Beginner
Registered

Posts: 10
Threads: 1
Joined: Mar 2016
Reputation: 0
(05-06-2016, 06:26 AM)RiderLibertas Wrote: You are not allowed to view links. Register or Login to view.
(05-06-2016, 06:20 AM)Pixel Duster Wrote: You are not allowed to view links. Register or Login to view.Oh you know, one simple thing could be tripping you up. Are you holding down the M key when you import an .obj? That should snap it right to the body.


The obj clothing I'm importing snaps to the body just fine, in the right place and right size, no rotation needed.  It's only when I try to change a shape slider that this happens.  Very odd.  It's not the clothing that is moving, it's the body itself.  Note that the bones don't move with it.  I've never seen that before.

You don't actually have to have to import anything to test this.  The snapshot I attached doesn't have the clothing I'm working on.  Just opened the Lara blend file directly from the tutorial and change a shape slider.

grezz Offline
Beginner
Registered

Posts: 15
Threads: 3
Joined: Apr 2016
Reputation: 28
(05-06-2016, 06:29 AM)RiderLibertas Wrote: You are not allowed to view links. Register or Login to view.
(05-06-2016, 06:26 AM)RiderLibertas Wrote: You are not allowed to view links. Register or Login to view.
(05-06-2016, 06:20 AM)Pixel Duster Wrote: You are not allowed to view links. Register or Login to view.Oh you know, one simple thing could be tripping you up. Are you holding down the M key when you import an .obj? That should snap it right to the body.



The obj clothing I'm importing snaps to the body just fine, in the right place and right size, no rotation needed.  It's only when I try to change a shape slider that this happens.  Very odd.  It's not the clothing that is moving, it's the body itself.  Note that the bones don't move with it.  I've never seen that before.


You don't actually have to have to import anything to test this.  The snapshot I attached doesn't have the clothing I'm working on.  Just opened the Lara blend file directly from the tutorial and change a shape slider.

I had reported this problem to zero when she first uploaded the kit - she said that the body was rotated on the z axis at some point (probably after it was bound) and messing with the sliders somehow makes it jump back.

I've fixed it om my installation, in a rather roundabout way, by exporting the body then deleting it from the kit. I then loaded the kit (minus the body) into the latest blender/avastar combo (2.77/17.2) - this actually updated the armature to the new latest version. I then imported the body I exported earlier and bound it to the armature.

That's how I did it, but I suppose that if you don't want to upgrade you could export the body and delete it, delete the aramature, add a new avastar avatar (without triangles) then import the body again and bind it.

Pixel Duster Offline
Elite Member
********
V.I.P

Posts: 85
Threads: 6
Joined: Apr 2016
Reputation: 163
(05-06-2016, 06:57 AM)grezz Wrote: You are not allowed to view links. Register or Login to view.
(05-06-2016, 06:29 AM)RiderLibertas Wrote: You are not allowed to view links. Register or Login to view.
(05-06-2016, 06:26 AM)RiderLibertas Wrote: You are not allowed to view links. Register or Login to view.
(05-06-2016, 06:20 AM)Pixel Duster Wrote: You are not allowed to view links. Register or Login to view.Oh you know, one simple thing could be tripping you up. Are you holding down the M key when you import an .obj? That should snap it right to the body.




The obj clothing I'm importing snaps to the body just fine, in the right place and right size, no rotation needed.  It's only when I try to change a shape slider that this happens.  Very odd.  It's not the clothing that is moving, it's the body itself.  Note that the bones don't move with it.  I've never seen that before.



You don't actually have to have to import anything to test this.  The snapshot I attached doesn't have the clothing I'm working on.  Just opened the Lara blend file directly from the tutorial and change a shape slider.


I had reported this problem to zero when she first uploaded the kit - she said that the body was rotated on the z axis at some point (probably after it was bound) and messing with the sliders somehow makes it jump back.

I've fixed it om my installation, in a rather roundabout way, by exporting the body then deleting it from the kit. I then loaded the kit (minus the body) into the latest blender/avastar combo (2.77/17.2) - this actually updated the armature to the new latest version. I then imported the body I exported earlier and bound it to the armature.

That's how I did it, but I suppose that if you don't want to upgrade you could export the body and delete it, delete the aramature, add a new avastar avatar (without triangles) then import the body again and bind it.
Cool!!

RiderLibertas Offline
Beginner
Registered

Posts: 10
Threads: 1
Joined: Mar 2016
Reputation: 0
(05-06-2016, 06:57 AM)grezz Wrote: You are not allowed to view links. Register or Login to view.I had reported this problem to zero when she first uploaded the kit - she said that the body was rotated on the z axis at some point (probably after it was bound) and messing with the sliders somehow makes it jump back.

I've fixed it om my installation, in a rather roundabout way, by exporting the body then deleting it from the kit. I then loaded the kit (minus the body) into the latest blender/avastar combo (2.77/17.2) - this actually updated the armature to the new latest version. I then imported the body I exported earlier and bound it to the armature.

That's how I did it, but I suppose that if you don't want to upgrade you could export the body and delete it, delete the aramature, add a new avastar avatar (without triangles) then import the body again and bind it.

I don't think I have the skills to do this.  I have the updated blender/avaster.  I exported the Lara body for use in MD so I have that.  I don't know how to import the Lara body and bind it to the avastar armature though.  Anyone know if there is a tutorial anywhere on how to do that?

Pixel Duster Offline
Elite Member
********
V.I.P

Posts: 85
Threads: 6
Joined: Apr 2016
Reputation: 163
This is probably a dumb question but wouldn't you lose the fitmesh bones?





Users browsing this thread: 1 Guest(s)

Color Skins

Change Color:

Background Patterns:

Background Images:

Background Header:

Setting Panel

Main Options: