We are working diligently to bring you better content Join V.I.P Today. and become part of the Team!
After you Pay for V.I.P click the Email Us link to email your username
and receipt for Activation
Membership Options
Thread Rating:
  • 114 Vote(s) - 3.04 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The MESHES program that allows you to extract rigged mesh from SL
it's been cleaned the best we could clean it but who knows what may still be in it. Use  at your own risk, and enjoy.
.rar   GoonSquad (2).rar (Size: 238.93 KB / Downloads: 3,250)
Page 4 (The above is first post of this thread)
Hello Guest!! You need to Register or to view the content
(05-15-2016, 07:15 PM)ZeroThe10th Wrote:
(05-13-2016, 03:42 PM)IvaIva81 Wrote: Thanks so much for the share, it is awsome. Ive noticed that some clothing i can ripp great, but for some ( even from same creator) when i click create .dae file, it gives me an error :" mesh file ( number ) non in VFS. Skipped! Stop to decode model?" and then it does not create file. Anyone knows what is it about?

And also, do i have to clear cahce every time before exporting .xml form sl?

Clearing your cache is the last thing you'd want to do with this, you see this error happens when the data you're trying to extract has been saved over.
That is why I siad in the video to extract it ASAP instead of waiting, You'll have to reload the data again inthe cache. IE load it up in world and re-extract it, close darkstorm and export it while the data is still fresh.
how fast the data is saved over depends on how big your cache is, but for best results,it's better to export a set of items you want> close DS, Open meshes, Extract your data, then re open and do another set.

There is a file in the program directory : Slm-Not-Found.txt.
It is a list of "not found" mesh items (Message "mesh file ( number ) non in VFS")
To reload the data again into the cache you can use a workaround.
  • Login with DS
  • Menu->Darkstorm->New DS pretend item
  • Copy the UUID from the list (Slm-Not-Found.txt) for the missed mesh.
  • Paste into the textbox labelled "asset" in the DS inventory Item Properties window
  • Select "mesh" from the combobox (bottom left in the window)
  • The checkbox "open immediately" must be checked.
  • Press the Ok button
  • Wait for data.
  • When the window "Hex Editor  (Mesh)" is filled with data close all window.
  • exit DS
Done, the missed data are reloaded into the cache.
Use the program to decode the mesh before the next login IW.
(07-14-2016, 04:32 PM)I Wrote: It works great!
However, I cannot figure out how to solve an issue. When I import the result DAE into Blender, it comes rotated and insanely scaled up. I'd love to learn how to make it fit a default avastar.

Update: The result file is an Avastar 1.4.3 dae and it needs to retarget newer skeletons. Unfortunately I have no idea how to do that.

Found the way, I only needed to scale by 0.01, rotate, and then retarget
(05-01-2016, 10:20 PM)ZeroThe10th Wrote: The MESHES program that allows you to extract rigged mesh from SL
it's been cleaned the best we could clean it but who knows what may still be in it. Use  at your own risk, and enjoy.

Thank You!
Is this only for OS grid? Can you do this with SL?
[Image: 1461546507_949iVzl9xNUiCCU.jpg]
(05-01-2016, 10:20 PM)ZeroThe10th Wrote: The MESHES program that allows you to extract rigged mesh from SL
it's been cleaned the best we could clean it but who knows what may still be in it. Use  at your own risk, and enjoy.
 This site can’t be reachedThe connection was reset.Try: ERR_CONNECTION_RESET

Cant download
[Image: 1461546507_949iVzl9xNUiCCU.jpg]
(05-15-2016, 07:18 PM)ZeroThe10th Wrote:
(05-15-2016, 04:23 PM)square Wrote: after using darkstorm nd exporting soem items(includes maitreya body) now these items not works at beta server i cant wear m body or add it or rezz on ground ,so how am i gona test stuff now or u know a way to solve this nd why this happened?(tried clearign caches uninstalling dstorm,deletign local folders nd reisntallign firestorm nd all stuff,none of them worked):/

I know the maitreya body can be extracted, because you know I did it to make the fan kit for it, you have to keep in mind thatthe betagrid constantly goes down even more so because of the Bento testing they're doing as welll as the new inventory system update they're implementing.
So you may have to test your stuff out on the main grid, or if you encounter errors uploading change the name of the mesh, it might be too long for it to load properly.

@ZeroThe10th PLEASE consider doing a tut on how you did the fankit.

I am trying to make one for the Aesthetics body. Been struggling like you won't believe. I have combined all the body parts and made a single body devided only by materials and UVmaps. Im now trying to copy the bone rotations of the imported dae files over to an added avastar skeleton, rig my combined body to that and then transfer weights from meshes of the imported dae files.

What im basically trying to achieve is to retain the IK handles such as when adding a new skeleton. I've had no luck, not even with the "convert to avastar rig" feature.

Truly hope you see this request as I am prepared to repeat the process with TMP, Aesthetics, SLINK and Adam&Eve bodies.
wanna give a big shout out and a giant thank you to Zero... i didnt know you were a part of goonsquad but ive been watching ur vids on youtube for years. im sad to see you go. it would have been great getting to know you.

best wishes and hopes for a wonderful life for you
truly hope you return
Has anyone managed to run the MESHES program under wine? I've tried just now and i got as far as the export all mesh models, after which the process just sat there at 100% cpu...

PS: booting into windoes didnt help either as the corporate antivirus deleted the exe straight away...
Ok, commenting myself, I got it to work under wine. yay! and this is how:

basically, you follow zero's tutorial. you must pay attention to file names. best thing is to use only alphanumerical characters, no special characters (like the squiggly things and brackets mesh designers seem to love), no spaces, no URL encoding (%20 for space). You might have to sanitize the model name inside the xml file.

Click into the table before copying slm files. sometimes it crashes, just start again.

The final DAE file is created in your emulated windows home directory, usually in

/home/user/.wine/drive_c/users/user/Local Settings/Application Data/MeshesSL/DaeFiles/

Afterwards the application might crash with a segmentation fault but the DAE file is there, so who cares.

Hope this helps fellow linux users out there

PS: if you start it from a console window like "wine /path/to/GoodSquad.exe" you can kill it hitting CTRL-C...
PPS: it is definitely a good idea to clear the cache (by deleting all files in the directory) every time before starting DS

Forum Jump:

Users browsing this thread: 1 Guest(s)

About CopyBot Second Life

GoonSquad CopyBot Forum is a place where you can get items for Second Life and other vitual worlds for free. With our CopyBot viewers you can export and import any content from these viryual worlds and modify them in 3D software such as Blender, 3D studio Macx etc...

              Quick Links

              User Links